The maintenance is taking longer than expected and will be extended by an additional 1 hour.
Posted Mar 28, 2026 - 15:11 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 28, 2026 - 14:15 UTC
Scheduled
We will undergo an unscheduled maintenance on 2026-03-28 2:00 PM (UTC +0), that will take approximately 30 minutes to 1 hour. Some services might not be available during the maintenance. We apologise for the inconvenience caused.
Posted Mar 28, 2026 - 14:09 UTC
This scheduled maintenance affected: MegaETH Etherscan (MegaETH Etherscan Mainnet (Web)).